www.TALKCENTO.com

Welcome to TalkCento: The New, FREE forum site for Fiat Cinquecento and Seicento owners!

Please register for FREE to join our community, and start discussing mechanics, and modifications for your car!

Also, join our Facebook page (simply search for TalkCento), and YouTube channel (www.youtube.com/TalkCento).

We hope you enjoy your stay!

The FREE forum site for Cento owners!


    Hi from theScottish Borders

    Share

    bigdave2200

    Posts : 2
    Join date : 2013-02-19
    Age : 65
    Location : Oxton, Scottish Borders

    Hi from theScottish Borders

    Post  bigdave2200 on Tue Feb 19, 2013 4:17 pm

    Hi all,new to the forum and just wanted to say hello. Just got myself a 2001 Sei sporting with 52000 on the clock. Seems to be in good nick apart from a couple of problems which seem to be common. 1)heater not blowing hot 2) rear wiper and washer not working and 3)will need new sump pan quite shortly. My Sei has the electric fabric sun roof which I'm told is quite rare, is that true? Anyway,I'm looking forward to joining in on the forum. Best wishes to youb all. Dave.
    avatar
    ShadowSei
    Moderator

    Posts : 71
    Join date : 2011-03-11
    Age : 32
    Location : Bedford

    Welcome to TalkCento!!

    Post  ShadowSei on Thu Feb 21, 2013 4:13 am

    bigdave2200 wrote:Hi all,new to the forum and just wanted to say hello. Just got myself a 2001 Sei sporting with 52000 on the clock. Seems to be in good nick apart from a couple of problems which seem to be common. 1)heater not blowing hot 2) rear wiper and washer not working and 3)will need new sump pan quite shortly. My Sei has the electric fabric sun roof which I'm told is quite rare, is that true? Anyway,I'm looking forward to joining in on the forum. Best wishes to youb all. Dave.

    Hi Dave and welcome to the forum. It's sad to say but the response may be slightly limited on here now cause everyones on Facebook. But then again saying that there are a couple of dedicated users on here that have stayed.

    So lets get you hopefully up and running properly again...

    1) Your Heater blowing cold: Could be a number of things really but try this - Check coolant levels and other areas like the oil cap to make sure there's no sign of water in the oil. Its like a Mustard'y texture and colour, Otherwise it could be expensive. (Basically your Headgasket has either gone or on the way out) Sad

    2) The rear wiper and washer jet is not working: Once again could be a number of things - Best to check the terminals on the boot lid (Just give them a good clean, if thats not it and you have a multimeter its best to check you have voltage coming through the other Springy terminals on the back of the car)

    If thats still not it, its probably a faulty wiper motor and they can easily be replaced.

    As for the washer jet - Fill the washer bottle with warm soapy water and arm yourself with a pin thats thin enough to poke down into the whole on the washer jet to unblock and grit/dirt preventing the solution from coming out. (Can you hear the washer motor buzzing/working when you pull the lever back? If so dont worry its not the motor) Also check the Pipe running to the back of the car, i know on mine that the rear tube was disconnected in the engine bay... Why it did; i don't know?

    3) Sump pan & parts Required: Talk to Cento Painter (Steve) He's breaking his Seicento and does great prices, but be quick as its the last chance of him putting it up. Surprised Very Happy Surprised You can also find it by clicking this link:
    4) Electric roof: Lecy roofs can be a nightmare, but they can be quite easy to get hold of the parts and material. Baring in mind if you look in the right places (But i warn you parts like this don't come cheap) affraid

    Hope this helps and let us know how you get on with it all. Have a look around and post up some pics of your Seicento when you want. If you have FB then will look to hear from you on that too. Very Happy


    _________________
    avatar
    cento painter

    Posts : 24
    Join date : 2013-02-12

    Re: Hi from theScottish Borders

    Post  cento painter on Fri Feb 22, 2013 10:37 am

    Welcome to the site !

    I would of said that roof is a rare option, after all most people have the glass ones in their cars.

    A few small niggly things, but nothing that could not be overcome for sure.

    How about some pics of that roof ? and car ?

    bigdave2200

    Posts : 2
    Join date : 2013-02-19
    Age : 65
    Location : Oxton, Scottish Borders

    Reply to responders

    Post  bigdave2200 on Fri Mar 01, 2013 8:48 pm

    Hi guys, thanks for welcome and advice. Right, checked all the heater bits an found matrix blocked solid Sad Got a new one from Euro Car Parts £38 plus vat (cheaper than online breakers). Fitted it in less than 2 hours and now car is toasty as hell. Next problem is damn thing wont select cold, think the temp selector cable is knackered.
    Done all the checks on rear wiper system. Motor definately goosed. Got one on order from e-bay and it's the rear washer pump thats f***ed so that's another problem sussed!
    Got a set of replacement fog lights and went to fit them today. Guess what, all the screws are corroded so it looks like a drill out job. Happy days!!
    I'll post photo's of car and it's roof soon as I get some decent weather.
    Even with the aforementioned hassles, I really love the little motor, talk about fun!!
    Hope you are all fine and look forward to chatting again soon.
    Dave.
    avatar
    cento painter

    Posts : 24
    Join date : 2013-02-12

    Re: Hi from theScottish Borders

    Post  cento painter on Fri Mar 01, 2013 10:36 pm

    Well im glad youre getting things sorted. If you need 2nd hand parts, let me know. I often break up Cinqs and Sei's.

    I just enjoy driving the little cars !!
    avatar
    ShadowSei
    Moderator

    Posts : 71
    Join date : 2011-03-11
    Age : 32
    Location : Bedford

    Reply

    Post  ShadowSei on Sun Mar 03, 2013 12:59 am

    Hi Dave,

    Glad you got most of the odd bits and bobs sorted out.
    If the cable is not selecting the cold setting, just do a quick check behind the center panel. (4 hex/allen bolts on each corner and one screw under the center selecter)

    You should be able to check the tension on that and adjust as you need to, it should be rather self explanatory when you take that panel off. You will be able to see if the cable is knackered or if its just caught on something.


    _________________

    Sponsored content

    Re: Hi from theScottish Borders

    Post  Sponsored content


      Current date/time is Sun Aug 19, 2018 5:24 am